Microsoft.EntityFrameworkCore.SqlServer.Abstractions 8.0.7

Prefix Reserved
There is a newer prerelease version of this package available.
See the version list below for details.

Requires NuGet 3.6 or higher.

dotnet add package Microsoft.EntityFrameworkCore.SqlServer.Abstractions --version 8.0.7                
NuGet\Install-Package Microsoft.EntityFrameworkCore.SqlServer.Abstractions -Version 8.0.7                
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Microsoft.EntityFrameworkCore.SqlServer.Abstractions" Version="8.0.7" />                
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Microsoft.EntityFrameworkCore.SqlServer.Abstractions --version 8.0.7                
#r "nuget: Microsoft.EntityFrameworkCore.SqlServer.Abstractions, 8.0.7"                
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Microsoft.EntityFrameworkCore.SqlServer.Abstractions as a Cake Addin
#addin nuget:?package=Microsoft.EntityFrameworkCore.SqlServer.Abstractions&version=8.0.7

// Install Microsoft.EntityFrameworkCore.SqlServer.Abstractions as a Cake Tool
#tool nuget:?package=Microsoft.EntityFrameworkCore.SqlServer.Abstractions&version=8.0.7                

Microsoft.EntityFrameworkCore.SqlServer.Abstractions is a small package containing abstractions which may be useful for applications in places where a dependency on the full Microsoft.EntityFrameworkCore.SqlServer is not desirable.

Usage

This package is included automatically as a dependency of the main Microsoft.EntityFrameworkCore.SqlServer package. Usually, the abstractions package is only explicitly installed in places where it is undesirable to use the main package. For example, it can be installed to use HierarchyId in POCO entity types which are otherwise independent of EF Core.

Getting started with EF Core

See Getting started with EF Core for more information about EF NuGet packages, including which to install when getting started.

Feedback

If you encounter a bug or issues with this package,you can open an Github issue. For more details, see getting support.

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.1 is compatible. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on Microsoft.EntityFrameworkCore.SqlServer.Abstractions:

Package Downloads
Microsoft.EntityFrameworkCore.SqlServer.HierarchyId

Adds hierarchyid support to the SQL Server EF Core provider

EntityFrameworkCore.InMemory.HierarchyId

Adds hierarchyid support to the in-memory EF Core provider

SNS.DataAccessLayer

Support functions for SNS, LightMapper, Live Electrochem, BioLED controller etc

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
9.0.0-preview.6.24327.4 63 7/9/2024
9.0.0-preview.5.24306.3 103 6/11/2024
9.0.0-preview.4.24267.1 104 5/21/2024
9.0.0-preview.3.24172.4 697 4/11/2024
9.0.0-preview.2.24128.4 188 3/12/2024
9.0.0-preview.1.24081.2 266 2/13/2024
8.0.7 4,796 7/9/2024
8.0.6 38,437 5/28/2024
8.0.5 221,730 5/14/2024
8.0.4 185,860 4/9/2024
8.0.3 60,476 3/12/2024
8.0.2 574,177 2/13/2024
8.0.1 31,907 1/9/2024
8.0.0 858,094 11/14/2023
8.0.0-rc.2.23480.1 3,378 10/10/2023
8.0.0-rc.1.23419.6 32,582 9/12/2023
8.0.0-preview.7.23375.4 2,567 8/8/2023
8.0.0-preview.6.23329.4 1,894 7/11/2023
8.0.0-preview.5.23280.1 3,334 6/13/2023
8.0.0-preview.4.23259.3 2,173 5/16/2023
8.0.0-preview.3.23174.2 203 4/11/2023
8.0.0-preview.2.23128.3 1,263 3/14/2023