DeveloperSharp 9.9.0

There is a newer version of this package available.
See the version list below for details.
dotnet add package DeveloperSharp --version 9.9.0
NuGet\Install-Package DeveloperSharp -Version 9.9.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="DeveloperSharp" Version="9.9.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add DeveloperSharp --version 9.9.0
#r "nuget: DeveloperSharp, 9.9.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install DeveloperSharp as a Cake Addin
#addin nuget:?package=DeveloperSharp&version=9.9.0

// Install DeveloperSharp as a Cake Tool
#tool nuget:?package=DeveloperSharp&version=9.9.0

DeveloperSharp是一个研发中大型项目必备的系统平台。也是一个低代码平台。

它主要包括了如下一些功能:
(1)基于Sql语句、存储过程、事务、分页的数据库操作。并几乎支持市面上所有种类的数据库。
(2)图片操作。裁剪、缩放、加水印。
(3)http请求调用(Post与Get)
(4)高效分页
(5)Web服务/WebApi的负载均衡
(6)数据库的负载均衡,以及读写分离
(7)CORS跨域访问
(8)UUID全球通用唯一识别码
(9)MQ消息队列(请另行使用DeveloperSharp.RabbitMQ包)
(10)Redis缓存(请另行使用DeveloperSharp.Redis包)
(11)“异种数据库”的负载均衡
(12)其它1...
(13)其它2...

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 is compatible.  netcoreapp2.1 was computed.  netcoreapp2.2 was computed.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Framework net45 is compatible.  net451 was computed.  net452 was computed.  net46 was computed.  net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 2.0

    • No dependencies.
  • .NETFramework 4.5

    • No dependencies.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
14.5.0 107 4/23/2024
14.0.0 113 4/16/2024
13.0.0 137 4/6/2024
12.0.0 101 4/2/2024
11.5.0 141 3/2/2024
11.0.0 112 2/29/2024
10.5.0 166 1/17/2024
10.2.0 329 12/7/2023
10.1.0 473 9/30/2023
10.0.0 166 9/29/2023
9.9.5 544 7/21/2023
9.9.0 892 12/4/2022
9.8.5 547 10/22/2022
9.8.0 430 10/21/2022
9.5.0 449 10/20/2022
9.0.0 501 10/6/2022
8.5.0 447 10/5/2022
8.0.0 480 10/5/2022
6.5.0 457 9/16/2022
6.0.0 435 9/15/2022