DOTSGeoPhonePlus2_Standard 1.1.0

dotnet add package DOTSGeoPhonePlus2_Standard --version 1.1.0                
NuGet\Install-Package DOTSGeoPhonePlus2_Standard -Version 1.1.0                
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="DOTSGeoPhonePlus2_Standard" Version="1.1.0" />                
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add DOTSGeoPhonePlus2_Standard --version 1.1.0                
#r "nuget: DOTSGeoPhonePlus2_Standard, 1.1.0"                
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install DOTSGeoPhonePlus2_Standard as a Cake Addin
#addin nuget:?package=DOTSGeoPhonePlus2_Standard&version=1.1.0

// Install DOTSGeoPhonePlus2_Standard as a Cake Tool
#tool nuget:?package=DOTSGeoPhonePlus2_Standard&version=1.1.0                

DOTS GeoPhone Plus 2

This package simplifies making API calls to GeoPhone Plus 2. It allows for testing on our trial environments and running against our production environments as well while implementing best practices and failover.

Examples

using ServiceObjects;

//Trial API
PhoneInfoResponse res = DOTSGPPL2.GetBestMatches("(805) 963-1700", "FULL", "XXXXXXXXXXX", false); Console.WriteLine(res);

//Production API
PhoneInfoResponse res = DOTSGPPL2.GetBestMatches("(805) 963-1700", "FULL", "XXXXXXXXXXX", true); Console.WriteLine(res);

//Async\

//Trial API
PhoneInfoResponse res = await DOTSGPPL2.GetBestMatchesAsync("(805) 963-1700", "FULL", "XXXXXXXXXXX", false); Console.WriteLine(res);

//Production API
PhoneInfoResponse res = await DOTSGPPL2.GetBestMatchesAsync("(805) 963-1700", "FULL", "XXXXXXXXXXX", true); Console.WriteLine(res);

Console.Read();

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 was computed.  netcoreapp2.1 was computed.  netcoreapp2.2 was computed.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.0 is compatible.  netstandard2.1 was computed. 
.NET Framework net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen40 was computed.  tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.1.0 587 8/19/2023

New package for integrating with .net framework and core.