gpgme-sharp 2.0.0

There is a newer version of this package available.
See the version list below for details.
dotnet add package gpgme-sharp --version 2.0.0
NuGet\Install-Package gpgme-sharp -Version 2.0.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="gpgme-sharp" Version="2.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add gpgme-sharp --version 2.0.0
#r "nuget: gpgme-sharp, 2.0.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install gpgme-sharp as a Cake Addin
#addin nuget:?package=gpgme-sharp&version=2.0.0

// Install gpgme-sharp as a Cake Tool
#tool nuget:?package=gpgme-sharp&version=2.0.0

gpgme-sharp

gpgme-sharp is a C# wrapper around GPGME, the recommended way to use GnuPG within an application. It supports .NET Framework 4.0 and higher, and .NET Standard 2.0 (including .NET Core 2.0).

NuGet version 

Requirements

  • On Windows, you will need to install Gpg4Win.
  • On Debian and Ubuntu, install the libgpgme11 package.
  • On other Linux distros or other operating systems, install libgpgme using your favourite package manager, or compile it from source.

Note that Gpg4Win currently only distributes a 32-bit build, so on Windows you must set your C# app to run in 32-bit mode.

Usage

The library can be installed using NuGet:

dotnet add package gpgme-sharp

See the Examples directory in this repo for usage examples.

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 was computed.  netcoreapp2.1 was computed.  netcoreapp2.2 was computed.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.0 is compatible.  netstandard2.1 was computed. 
.NET Framework net40 is compatible.  net403 was computed.  net45 was computed.  net451 was computed.  net452 was computed.  net46 was computed.  net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen40 was computed.  tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.0.0-beta1 220 12/6/2023
2.0.3 59,126 3/24/2019
2.0.2 707 2/24/2019
2.0.1 1,565 2/10/2019
2.0.0 696 1/31/2019

Update to support .NET Standard 2.0