WindowsAPICodePackShell 8.0.2

dotnet add package WindowsAPICodePackShell --version 8.0.2
NuGet\Install-Package WindowsAPICodePackShell -Version 8.0.2
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="WindowsAPICodePackShell" Version="8.0.2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add WindowsAPICodePackShell --version 8.0.2
#r "nuget: WindowsAPICodePackShell, 8.0.2"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install WindowsAPICodePackShell as a Cake Addin
#addin nuget:?package=WindowsAPICodePackShell&version=8.0.2

// Install WindowsAPICodePackShell as a Cake Tool
#tool nuget:?package=WindowsAPICodePackShell&version=8.0.2

Microsoft Windows API Codepack

README

Current Version

License

The library is not developed anymore by Microsoft and seems to have been left as 'free to use'. A clarification or update about the licence terms from Microsoft is welcome, however.

Release notes

This release has the latest bug fixes applied, including the fix for 64-bit exceptions.

Bugs

When you submit a bug:

  • provide a short example code showing the bug
  • describe the expected behavior/result
  • if a pull request is applicable, please reference it

Pull Requests

I'll be glad to accept pull requests if they fix a bug or add a worthwhile feature.

Usage notes

TaskDialog

If you get the following exception when you instantiate a TaskDialog:

An unhandled exception of type 'System.NotSupportedException' occurred in Microsoft.WindowsAPICodePack.dll

Additional information: TaskDialog feature needs to load version 6 of comctl32.dll but a different version is current loaded in memory.

To fix it, create an application manifest and un-comment the following block section:

  
  

Note: you might have to restart Visual Studio as the DLLs seems to be cached in memory and rebuilding your project doesn't seem to be enough in some cases.

DirectX

The DirectX package will work under x86 and x64 configuration platforms but not for AnyCPU platform (because there is no such platform for C++/CLI projects). Consequently, the package will purposefully fail the build and tell you why it did.

Note: package is here for historical reasons, it is highly recommended to use SharpDX instead.

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net5.0-windows7.0 is compatible.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net6.0-windows7.0 is compatible.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net7.0-windows7.0 is compatible.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed.  net8.0-windows7.0 is compatible.  net9.0-windows7.0 is compatible. 
.NET Core netcoreapp3.1 is compatible. 
.NET Framework net462 is compatible.  net463 was computed.  net47 is compatible.  net471 is compatible.  net472 is compatible.  net48 is compatible.  net481 is compatible. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (14)

Showing the top 5 NuGet packages that depend on WindowsAPICodePackShell:

Package Downloads
Krypton.Toolkit.Suite.Extended.Dialogs

An extension to the Standard Toolkit, which supports .NET Framework 4.6.2 - 4.8.1, .NET Core 3.1 and .NET 5 - 7. This package implements additional extensions to standard dialogs. This package supports all .NET Framework versions starting .NET Framework 4.6.2 - 4.8.1, .NET Core 3.1 and .NET 5 - 7. Also, all libraries are included targeting each specific framework version for performance purposes. To view all of the extended toolkit package latest version information, please visit: https://github.com/Krypton-Suite/Krypton-Toolkit-Suite-Version-Dashboard/blob/main/Documents/Modules/Extended/Krypton-Toolkit-Suite-Extended-Modules.md

Krypton.Toolkit.Suite.Extended.Theme.Switcher.Nightly

An extension to the Standard Toolkit, which supports .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. This package implements a easy to use theme switcher. This package supports all .NET Framework versions starting .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. Also, all libraries are included targeting each specific framework version for performance purposes. To view all of the extended toolkit package latest version information, please visit: https://github.com/Krypton-Suite/Krypton-Toolkit-Suite-Version-Dashboard/blob/main/Documents/Modules/Extended/Krypton-Toolkit-Suite-Extended-Modules.md

Krypton.Toolkit.Suite.Extended.Dialogs.Nightly

An extension to the Standard Toolkit, which supports .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. This package implements additional extensions to standard dialogs. This package supports all .NET Framework versions starting .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. Also, all libraries are included targeting each specific framework version for performance purposes. To view all of the extended toolkit package latest version information, please visit: https://github.com/Krypton-Suite/Krypton-Toolkit-Suite-Version-Dashboard/blob/main/Documents/Modules/Extended/Krypton-Toolkit-Suite-Extended-Modules.md

Krypton.Toolkit.Suite.Extended.Buttons.Nightly

An extension to the Standard Toolkit, which supports .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. This package holds extensions to the KryptonButton controls. This package supports all .NET Framework versions starting .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. Also, all libraries are included targeting each specific framework version for performance purposes. To view all of the extended toolkit package latest version information, please visit: https://github.com/Krypton-Suite/Krypton-Toolkit-Suite-Version-Dashboard/blob/main/Documents/Modules/Extended/Krypton-Toolkit-Suite-Extended-Modules.md

Krypton.Toolkit.Suite.Extended.File.Copier.Nightly

An extension to the Standard Toolkit, which supports .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. This package provides tools to move and copy files. This package supports all .NET Framework versions starting .NET Framework 4.6.2 - 4.8.1, .NET 6, 8 and 9. Also, all libraries are included targeting each specific framework version for performance purposes. To view all of the extended toolkit package latest version information, please visit: https://github.com/Krypton-Suite/Krypton-Toolkit-Suite-Version-Dashboard/blob/main/Documents/Modules/Extended/Krypton-Toolkit-Suite-Extended-Modules.md

GitHub repositories (3)

Showing the top 3 popular GitHub repositories that depend on WindowsAPICodePackShell:

Repository Stars
Krypton-Suite/Extended-Toolkit
A companion toolkit for the standard toolkit.
VladimirKhil/SI
SIGame and related products
Crauzer/lol2gltf
Convert between League of Legends mesh formats and the glTF runtime format
Version Downloads Last updated
8.0.2 724 2/24/2024
8.0.1 241 2/14/2024
8.0.0 1,160 11/14/2023
7.0.4 6,400 2/26/2023
7.0.3 638 2/17/2023
7.0.2 486 2/4/2023
7.0.1 6,454 11/15/2022
7.0.0 329 11/13/2022
1.1.3 903 6/25/2022
1.1.2 30,826 6/22/2021
1.1.1 2,121 1/25/2020
1.1.0 4,767 10/28/2015