SkyAPM.Utilities.DependencyInjection 2.1.0

There is a newer version of this package available.
See the version list below for details.
dotnet add package SkyAPM.Utilities.DependencyInjection --version 2.1.0
NuGet\Install-Package SkyAPM.Utilities.DependencyInjection -Version 2.1.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="SkyAPM.Utilities.DependencyInjection" Version="2.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add SkyAPM.Utilities.DependencyInjection --version 2.1.0
#r "nuget: SkyAPM.Utilities.DependencyInjection, 2.1.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install SkyAPM.Utilities.DependencyInjection as a Cake Addin
#addin nuget:?package=SkyAPM.Utilities.DependencyInjection&version=2.1.0

// Install SkyAPM.Utilities.DependencyInjection as a Cake Tool
#tool nuget:?package=SkyAPM.Utilities.DependencyInjection&version=2.1.0

Microsoft.Utilities.DependencyInjection (IServiceCollection) support for SkyAPM.

Product Compatible and additional computed target framework versions.
.NET net5.0 is compatible.  net5.0-windows was computed.  net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.1 is compatible. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (37)

Showing the top 5 NuGet packages that depend on SkyAPM.Utilities.DependencyInjection:

Package Downloads
SkyAPM.Diagnostics.EntityFrameworkCore

SkyApm.Diagnostics.EntityFrameworkCore notifies of EF requests.

SkyAPM.Diagnostics.SqlClient

SkyAPM.Diagnostics.SqlClient notifies outgoing SqlClient requests.

SkyAPM.Diagnostics.EntityFrameworkCore.Pomelo.MySql

SkyAPM.Diagnostics.EntityFrameworkCore.Pomelo.MySql notifies of EF requests.

SkyAPM.Diagnostics.HttpClient

SkyAPM.Diagnostics.HttpClient notifies outgoing Http requests.

SkyAPM.Diagnostics.EntityFrameworkCore.Sqlite

SkyAPM.Diagnostics.EntityFrameworkCore.Sqlite notifies of EF requests.

GitHub repositories (3)

Showing the top 3 popular GitHub repositories that depend on SkyAPM.Utilities.DependencyInjection:

Repository Stars
SkyAPM/SkyAPM-dotnet
The .NET/.NET Core instrument agent for Apache SkyWalking
SkyChenSky/Sikiro
整合了社区主流开源框架(CAP、SkyAPM、WebAPIClient、Chloe等)的微服务项目示例
liuhll/silky
The Silky framework is designed to help developers quickly build a microservice development framework through simple code and configuration under the .net platform.
Version Downloads Last updated
2.2.0 2,845 3/31/2024
2.1.0 277,413 9/27/2022
2.0.1 34,526 8/4/2022
2.0.0 51,539 5/11/2022
1.3.0 355,138 5/15/2021
1.2.0 83,880 1/28/2021
1.2.0-preview-128523807 5,076 1/27/2021
1.1.0 95,238 12/8/2020
1.0.0 122,922 9/7/2020
0.9.0 521,118 6/30/2019
0.8.0 71,110 2/16/2019
0.8.0-prerelease-66885637 4,744 2/14/2019
0.8.0-prerelease-66843215 4,754 2/13/2019
0.8.0-prerelease-66795016 4,785 2/13/2019