R.NET.FSharp 1.8.1

A .NET interoperability library to access the R statistical language runtime from .NET languages. The library is designed for fast data exchange, in process.

There is a newer version of this package available.
See the version list below for details.
Install-Package R.NET.FSharp -Version 1.8.1
dotnet add package R.NET.FSharp --version 1.8.1
<PackageReference Include="R.NET.FSharp" Version="1.8.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add R.NET.FSharp --version 1.8.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: R.NET.FSharp, 1.8.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install R.NET.FSharp as a Cake Addin
#addin nuget:?package=R.NET.FSharp&version=1.8.1

// Install R.NET.FSharp as a Cake Tool
#tool nuget:?package=R.NET.FSharp&version=1.8.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
  • R.NET can now also run on all recent R versions in the 3.4 and 3.5 series. While not extensively tested any of the R 3.X series should be supported. Note that on Linux only 3.5.y is supported due to a difficulty in detecting R versions on that OS.
  • R.NET assemblies now target netstandard2.0 and support .NET core (2.0) and .NET framework (4.6.1+ but preferably 4.7.2 see .NET implementation support )
  • Key contributions by Luke Rasmussen, David Pendray and others are gratefully acknowledged to make this release possible
  • R.NET can now also run on all recent R versions in the 3.4 and 3.5 series. While not extensively tested any of the R 3.X series should be supported. Note that on Linux only 3.5.y is supported due to a difficulty in detecting R versions on that OS.
  • R.NET assemblies now target netstandard2.0 and support .NET core (2.0) and .NET framework (4.6.1+ but preferably 4.7.2 see .NET implementation support )
  • Key contributions by Luke Rasmussen, David Pendray and others are gratefully acknowledged to make this release possible

Release Notes

Migration to .NET Standard 2.0, support for R 3.5.x, and moving to an MIT license

NuGet packages (2)

Showing the top 2 NuGet packages that depend on R.NET.FSharp:

Package Downloads
R.NET.Community.FSharp
Transitional package, you can remove and directly use nuget package ID R.NET.FSharp
RDotNet.FSharp
Transitional package, you can remove and directly use nuget package ID R.NET.FSharp

GitHub repositories

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.9.0 424 10/4/2020
1.8.2 481 5/20/2019
1.8.1 298 5/4/2019
1.8.0 291 5/4/2019
1.8.0-alpha2 264 5/4/2019
1.8.0-alpha 343 4/22/2019
1.7.0 5,570 8/29/2017