FluentExcel 1.1.0

.NET Framework 4.5
There is a newer version of this package available.
See the version list below for details.
NuGet\Install-Package FluentExcel -Version 1.1.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
dotnet add package FluentExcel --version 1.1.0
<PackageReference Include="FluentExcel" Version="1.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FluentExcel --version 1.1.0
#r "nuget: FluentExcel, 1.1.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install FluentExcel as a Cake Addin
#addin nuget:?package=FluentExcel&version=1.1.0

// Install FluentExcel as a Cake Tool
#tool nuget:?package=FluentExcel&version=1.1.0

Use Fluent API to configure POCO excel behaviors, and then provides IEnumerable<T> save to and load from excel functionalities.

Product Versions
.NET Framework net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (2)

Showing the top 2 NuGet packages that depend on FluentExcel:

Package Downloads
Etch.OrchardCore.SEO

Module for Orchard Core that provides useful features for SEO.

TestExtentions.Common

Test Extention for Selenium

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.2.0 23,073 7/10/2018
1.2.2 1,255 1/1/2018
1.2.1 830 11/20/2017
1.2.0 907 9/21/2017
1.1.3 882 7/31/2017
1.1.1 979 7/28/2017
1.1.0 719 7/27/2017

1. Decouple the configuration from the POCO model by using fluent api; 2. Support POCO, so that if your mother langurage is Engilish, none any configurations;