FlashMapper 1.0.5-beta2

.NET Standard 2.0 .NET Framework 4.0
This is a prerelease version of FlashMapper.
NuGet\Install-Package FlashMapper -Version 1.0.5-beta2
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
dotnet add package FlashMapper --version 1.0.5-beta2
<PackageReference Include="FlashMapper" Version="1.0.5-beta2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FlashMapper --version 1.0.5-beta2
#r "nuget: FlashMapper, 1.0.5-beta2"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install FlashMapper as a Cake Addin
#addin nuget:?package=FlashMapper&version=1.0.5-beta2&prerelease

// Install FlashMapper as a Cake Tool
#tool nuget:?package=FlashMapper&version=1.0.5-beta2&prerelease

.net-library that allows you to map properties of two classes and then use result mapping to convert from one to another.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net40 net403 net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETFramework 4.0

    • No dependencies.
  • .NETStandard 2.0

    • No dependencies.

NuGet packages (3)

Showing the top 3 NuGet packages that depend on FlashMapper:

Package Downloads
FlashMapper.MultiSource

Extension for FlashMapper that allows to map data from multiple sources.

FlashMapper.DependencyInjection

Extension library for FlashMapper that provides you with an API to move every mapping configuration into standalone service.

FlashMapper.DependancyInjection

This package is no longer supported due to a typo in the name. Please install package named 'FlashMapper.DependencyInjection'.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.5-beta2 3,179 5/18/2018
1.0.5-beta1 753 5/18/2018
1.0.4 1,197 1/16/2018
1.0.3 1,025 1/14/2018
1.0.1 1,132 7/30/2017

ConstructionOnly, UpdateOnly markers