Data8.PowerPlatform.Dataverse.Client 0.2.2

There is a newer version of this package available.
See the version list below for details.
dotnet add package Data8.PowerPlatform.Dataverse.Client --version 0.2.2
NuGet\Install-Package Data8.PowerPlatform.Dataverse.Client -Version 0.2.2
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Data8.PowerPlatform.Dataverse.Client" Version="0.2.2" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Data8.PowerPlatform.Dataverse.Client --version 0.2.2
#r "nuget: Data8.PowerPlatform.Dataverse.Client, 0.2.2"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Data8.PowerPlatform.Dataverse.Client as a Cake Addin
#addin nuget:?package=Data8.PowerPlatform.Dataverse.Client&version=0.2.2

// Install Data8.PowerPlatform.Dataverse.Client as a Cake Tool
#tool nuget:?package=Data8.PowerPlatform.Dataverse.Client&version=0.2.2

Data8 .NET Core Client SDK for On-Premise IFD Dynamics 365

The Microsoft.PowerPlatform.Dataverse.Client package provides an SDK for connecting to Dataverse & Dynamics 365 instances from .NET Core, but relies on OAuth authentication. This poses a problem when you need to connect to an on-premise instance that either does not support OAuth, or where the OAuth tokens regularly expire and cannot be automatically refreshed.

This package Data8.PowerPlatform.Dataverse.Client builds on top of the Microsoft one and offers an alternative IOrganizationService implementation using WS-Trust. This allows you to connect using the URL of the organization service, username and password without any additional configuration.

Because this OnPremiseClient implements the same IOrganizationService as the standard ServiceClient implementation your code can work with either as shown in the sample code below.

Sample

using Data8.PowerPlatform.Dataverse.Client;
using Microsoft.PowerPlatform.Dataverse.Client;
using Microsoft.Xrm.Sdk;

var onPrem = new OnPremiseClient("https://org.crm.contoso.com/XRMServices/2011/Organization.svc", "AD\\username", "password!");
var online = new ServiceClient("AuthType=ClientSecret;Url=https://contoso.crm.dynamics.com;ClientId=637C79F7-AE71-4E9A-BD5B-1EC5EC9F397A;ClientSecret=p1UiydoIWwUH5AdMbiVBOrEYn8t4RXud");

CreateRecord(onPrem);
CreateRecord(online);

void CreateRecord(IOrganizationService svc)
{
	var entity = new Entity("account")
	{
		["name"] = "Data8"
	};

	entity.Id = svc.Create(entity);
}

Compatibility

This package is designed to be used with on-premise Dynamics 365 instances configured with claims-based authentication. An Internet Facing Deployment is also supported but not required.

Integrated Windows Authentication is not supported.

The package targets .NET Core 3.1 or later.

Support and Contributing

This package is not officially supported, either by Data8 or Microsoft. We will attempt to provide support on a best-efforts basis via GitHub issues but can't guarantee we will be able to resolve any specific issues you may have.

Contributions to the package are welcome in the form of suggestions via Issues or bug fixes/enhancements via Pull Requests.

Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp3.1 is compatible. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.4.2 468 5/29/2024
2.4.1 13,662 9/26/2023
2.4.0 3,807 9/5/2023
2.3.2 6,172 8/24/2023
2.3.1 22,023 11/18/2022
2.3.0 9,445 10/21/2022
2.2.0 3,704 9/12/2022
2.1.1 2,942 6/16/2022
2.1.0 637 5/19/2022
2.0.2 2,457 4/25/2022
2.0.1 754 3/24/2022
2.0.0 475 3/10/2022
1.0.0 553 11/15/2021
0.2.2 335 11/10/2021
0.2.1 325 11/9/2021
0.2.0 319 11/9/2021
0.1.0 373 11/9/2021

First release