Allure.NUnit 2.12.0

There is a newer version of this package available.
See the version list below for details.
dotnet add package Allure.NUnit --version 2.12.0
NuGet\Install-Package Allure.NUnit -Version 2.12.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Allure.NUnit" Version="2.12.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Allure.NUnit --version 2.12.0
#r "nuget: Allure.NUnit, 2.12.0"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Allure.NUnit as a Cake Addin
#addin nuget:?package=Allure.NUnit&version=2.12.0

// Install Allure.NUnit as a Cake Tool
#tool nuget:?package=Allure.NUnit&version=2.12.0

Allure NUnit adapter

Nuget Nuget pre

Nuget downloads

An Allure adapter for NUnit.

<img src="https://allurereport.org/public/img/allure-report.svg" height="85px" alt="Allure Report logo" align="right" />


Quick start

  • Install the Allure.NUnit package.
  • Configure it via allureConfig.json.
  • Apply the [Allure.NUnit.AllureNUnit] attribute to test fixtures.
  • Use other attributes from Allure.NUnit.Attributes if needed.
  • Use the functions from Allure.Net.Commons.AllureApi if needed.

Further readings

Learn more from the documentation for Allure NUnit.

Some examples are available here.

Notes

Namespace changed to Allure.NUnit

Starting from 2.12.0, the namespace NUnit.Allure is deprecated. The API in that namespace still works, but it will be removed in the future. Please use Allure.NUnit instead.

The [NUnit.Allure.Core.AllureNUnit] attribute should be replaced with [Allure.NUnit.AllureNUnit]:

using Allure.NUnit; // <- Note the namespace
using NUnit.Framework;

[AllureNUnit]
class MyTests
{
    [Test]
    public void TestMethod()
    {
        /* ... */
    }
}

Deprecations and removals in 2.12.0

The following user API methods are now deprecated:

  • In NUnit.Allure.Core.AllureExtensions:
    • All overloads of WrapInStep - use Allure.Net.Commons.AllureApi.Step instead.
    • WrapSetUpTearDownParams - had no effect; can safely be replaced with the direct call of the provided delegate.
  • NUnit.Allure.Core.AllureNUnitAttribute - use Allure.NUnit.AllureNUnitAttribute instead.
  • Other classes and methods in NUnit.Allure - change the namespace to Allure.NUnit.

The following previously deprecated user API classes and methods were removed:

  • In NUnit.Allure.Core.AllureExtensions:
    • AddScreenDiff - use Allure.Net.Commons.AllureApi.AddScreenDiff instead.
  • NUnit.Allure.Core.AllureNUnitAttribute's constructor overload that takes bool wrapIntoStep - the wrapIntoStep parameter had no effect and can be safely removed now.
  • In NUnit.Allure.Core.AllureNUnitHelper:
    • WrapInStep - use Allure.Net.Commons.AllureApi.Step instead.
  • NUnit.Allure.Core.StepsHelper - use functions from Allure.Net.Commons.AllureApi and Allure.Net.Commons.ExtendedApi instead.
  • In Allure.Net.Commons.AllureLifecycle:
    • AddAttachment - use Allure.Net.Commons.AllureApi.AddAttachment instead.
    • AddScreenDiff - use Allure.Net.Commons.AllureApi.AddScreenDiff instead.
  • Allure.Net.Commons.Steps.CoreStepsHelper - use functions from Allure.Net.Commons.AllureApi and Allure.Net.Commons.ExtendedApi instead.

For users of Mac with Apple silicon

If you're developing on a Mac machine with Apple silicon, make sure you have Rosetta installed. Follow this article for the instructions: https://support.apple.com/en-us/HT211861

You may also install Rosetta via the CLI:

/usr/sbin/softwareupdate --install-rosetta --agree-to-license
Product Compatible and additional computed target framework versions.
.NET net5.0 was computed.  net5.0-windows was computed.  net6.0 was computed.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
.NET Core netcoreapp2.0 was computed.  netcoreapp2.1 was computed.  netcoreapp2.2 was computed.  netcoreapp3.0 was computed.  netcoreapp3.1 was computed. 
.NET Standard netstandard2.0 is compatible.  netstandard2.1 was computed. 
.NET Framework net461 was computed.  net462 was computed.  net463 was computed.  net47 was computed.  net471 was computed.  net472 was computed.  net48 was computed.  net481 was computed. 
MonoAndroid monoandroid was computed. 
MonoMac monomac was computed. 
MonoTouch monotouch was computed. 
Tizen tizen40 was computed.  tizen60 was computed. 
Xamarin.iOS xamarinios was computed. 
Xamarin.Mac xamarinmac was computed. 
Xamarin.TVOS xamarintvos was computed. 
Xamarin.WatchOS xamarinwatchos was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.12.1 2,514 6/4/2024
2.12.0 20,934 4/2/2024
2.11.0 63,002 11/29/2023
2.10.0 22,736 10/16/2023
2.10.0-preview.1 4,545 9/22/2023
2.9.5-preview.1 93,354 3/22/2023
2.9.4-preview.6 46,072 2/13/2023
2.9.4-preview.2 13,740 1/2/2023
2.9.4-preview.1 153 12/30/2022
2.9.3-preview.1 4,234 12/23/2022
2.9.2-preview.1 11,955 9/19/2022
2.9.1-preview.7-nunit-fixtures 1,817 8/2/2022
2.9.1-preview.6-nunit-fixtures 122 7/27/2022
2.9.1-preview.5 164 7/27/2022