vm.Aspects.Security.Cryptography.Ciphers.ProtectedData 2.1.4

.NET Standard 2.0
Install-Package vm.Aspects.Security.Cryptography.Ciphers.ProtectedData -Version 2.1.4
dotnet add package vm.Aspects.Security.Cryptography.Ciphers.ProtectedData --version 2.1.4
<PackageReference Include="vm.Aspects.Security.Cryptography.Ciphers.ProtectedData" Version="2.1.4" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add vm.Aspects.Security.Cryptography.Ciphers.ProtectedData --version 2.1.4
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: vm.Aspects.Security.Cryptography.Ciphers.ProtectedData, 2.1.4"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install vm.Aspects.Security.Cryptography.Ciphers.ProtectedData as a Cake Addin
#addin nuget:?package=vm.Aspects.Security.Cryptography.Ciphers.ProtectedData&version=2.1.4

// Install vm.Aspects.Security.Cryptography.Ciphers.ProtectedData as a Cake Tool
#tool nuget:?package=vm.Aspects.Security.Cryptography.Ciphers.ProtectedData&version=2.1.4
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

THE CLASSES FROM THE CIPHERS PACKAGES DO NOT IMPLEMENT ANY CRYPTOGRAPHIC ALGORITHMS. They leverage the cryptographic algorithms implemented by the .NET cryptographic service providers.

           This package extends vm.Aspects.Security.Cryptography.Ciphers with classes dependent on System.Security.Cryptography.ProtectedData which depends on the Windows Data Protection API (DPAPI). The package can be expected to work on Windows OS only.
           * The package depends on:
           - .NET Standard
           - System.Security.Cryptography.Xml
           - System.Security.Cryptography.ProtectedData
           - vm.Aspects.Security.Cryptography.Ciphers
           - vm.Aspects.Security.Cryptography.Ciphers.Xml

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
2.1.4 1,099 9/3/2018

Note: this package inherits from the Ciphers package but the name has changed for consistency's sake with the other vm.Aspects packages.
           Refactored the library to drop the dependency on Common Service Locator - no assumption of DI container anymore.
           Refactored a number of c-tors to take additional dependencies, which were previously resolved from the CSL.
           Built and tested with .NET Standard 2.0.