paket.bootstrapper 1.4.0

A package dependency manager for .NET with support for NuGet packages and GitHub repositories.

There is a newer version of this package available.
See the version list below for details.
Install-Package paket.bootstrapper -Version 1.4.0
dotnet add package paket.bootstrapper --version 1.4.0
<PackageReference Include="paket.bootstrapper" Version="1.4.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add paket.bootstrapper --version 1.4.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Release Notes

EXPERIMENTAL: Find-Packages command
EXPERIMENTAL: Find-Package-Versions command
EXPERIMENTAL: Show-Installed-Packages for given project command
EXPERIMENTAL: Show-Installed-Packages command
Expose GetDefinedNuGetFeeds in Public API
Expose GetSources in Public API
BUGFIX: NuGet Convert works with empty version strings - https://github.com/fsprojects/Paket/pull/821
BUGFIX: Don't shortcut conflicting addition
BUGFIX: Better pin down behaviour during "Smart Update""
BUGFIX: Only replace nuget package during add if the old one had no version
BUGFIX: Put fixed packages to the end - https://github.com/fsprojects/Paket/issues/814
BUGFIX: Fix `paket add` if package is already there - https://github.com/fsprojects/Paket/issues/814
BUGFIX: Fix `paket add` for very first dependency - https://github.com/fsprojects/Paket/issues/814
BUGFIX: Paket pack had issues with \ in subfolders - https://github.com/fsprojects/Paket/issues/812
BZGFIX: Use https://api.nuget.org/v3/index.json for Autocomplete
BUGFIX: Set exit code to 1 if the command line parser finds error
BUGFIX: Windows restrictions were not parsed from lockfile - https://github.com/fsprojects/Paket/issues/810
BUGFIX: Paket tries to keep the alphabetical order when using `paket add`
BUGFIX: Do not generate entries for empty extensions in nupkg
BUGFIX: Portable framework restrictions were not parsed from lockfile - https://github.com/fsprojects/Paket/issues/810
COSMETICS: "Done" message in bootstrapper
COSMETICS: -s parameter for Bootstrapper
COSMETICS: Don't perform unnecessary installs during `paket add`
COSMETICS: Always print the command on command parser error

Dependencies

This package has no dependencies.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
6.0.0-alpha001 46 12/2/2019
5.237.0 191 11/25/2019
5.220.0 319 9/30/2019
5.164.0 1,266 5/17/2018
5.141.0 548 2/23/2018
5.140.0 282 2/23/2018
5.126.0 413 12/12/2017
5.125.5 364 12/11/2017
5.125.4 370 12/11/2017
5.124.0 332 11/29/2017
5.122.0 329 11/7/2017
5.105.0 324 10/4/2017
5.100.1 270 9/22/2017
5.100.0 264 9/22/2017
5.92.2 295 9/3/2017
5.81.0 355 7/21/2017
5.0.0 380 6/16/2017
5.0.0-rc001 274 6/6/2017
5.0.0-beta010 272 6/2/2017
4.7.0 384 4/25/2017
4.0.0 368 3/15/2017
4.0.0-alpha009 348 10/25/2016
4.0.0-alpha008 323 10/25/2016
3.35.0 403 1/30/2017
3.32.0 409 1/2/2017
3.27.0 399 11/10/2016
3.25.0 371 10/28/2016
3.24.0 337 10/25/2016
3.24.0-alpha001 288 10/22/2016
3.14.0 448 8/22/2016
3.0.0 557 6/15/2016
2.62.0 425 4/17/2016
2.46.0 594 1/19/2016
2.34.0 3,023 12/7/2015
2.31.0 382 12/1/2015
2.29.0 360 11/27/2015
2.27.0 378 11/19/2015
2.4.0 404 9/28/2015
1.39.0 408 9/8/2015
1.25.0 383 8/10/2015
1.11.0 408 6/8/2015
1.4.0 433 5/8/2015
1.2.2 383 4/27/2015
1.2.0 403 4/24/2015
Show less