Sustainable.Web.Mvc.HibpClientValidator 1.0.20190219.1235

The client validator will (using javascript and unobtrusive client validation) tell the user if the typed password has been previously leaked. It will not tell how many times a password has been used as it is not relevant. If it has been leaked, it should not be used again.
   
   The package DOES depend on MVC for both Core and Framework, but has explicitly removed the dependencies for nuget. Minimum required MVC version is 5.0.1. For ASP.Net core MVC, you must download and reference the javascript manually (https://github.com/zealofzebras/HibpClientValidator/blob/master/HibpClientValidatorNuget/hibpvalidator.core.js)

Install-Package Sustainable.Web.Mvc.HibpClientValidator -Version 1.0.20190219.1235
dotnet add package Sustainable.Web.Mvc.HibpClientValidator --version 1.0.20190219.1235
<PackageReference Include="Sustainable.Web.Mvc.HibpClientValidator" Version="1.0.20190219.1235" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Sustainable.Web.Mvc.HibpClientValidator --version 1.0.20190219.1235
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

  • .NETFramework 4.5

    • No dependencies.
  • .NETStandard 2.0

    • No dependencies.

This package is not used by any popular GitHub repositories.

Version History

Version Downloads Last updated
1.0.20190219.1235 168 2/19/2019
1.0.20190219.1205 98 2/19/2019