Realm 10.7.1

Install-Package Realm -Version 10.7.1
dotnet add package Realm --version 10.7.1
<PackageReference Include="Realm" Version="10.7.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Realm --version 10.7.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Realm, 10.7.1"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Realm as a Cake Addin
#addin nuget:?package=Realm&version=10.7.1

// Install Realm as a Cake Tool
#tool nuget:?package=Realm&version=10.7.1
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Realm is a mobile database: a replacement for SQLite

NuGet packages (20)

Showing the top 5 NuGet packages that depend on Realm:

Package Downloads
ppy.osu.Game

Package Description

Iridium360.Connect.Framework

This framework allows you to bind your Android or iOS device with i360RockSTAR tracker

Hangfire.Realm

This Hangfire extension adds support for using the lightweight embeddable Realm object database.

ItEnterprise.Common.CoreStandard

ItEnterprise Common.CoreStandard for Xamarin Forms

ItEnterprise.WmsStandard

ItEnterprise WmsStandard for Xamarin Forms

GitHub repositories (5)

Showing the top 5 popular GitHub repositories that depend on Realm:

Repository Stars
ppy/osu
rhythm is just a *click* away!
realm/realm-dotnet
Realm is a mobile database: a replacement for SQLite & ORMs
sgermosen/xReader
XML, NEWS, RSS & Scrapping Reader maked in Xamarin, for educational purpose.
realm/realm-draw
The official Realm Draw app used in promotional videos
dsa28s/windows-hangul-clock
Hangul Clock for Windows Desktop Widget
Version Downloads Last updated
10.7.1 7,358 11/20/2021
10.7.0 993 11/10/2021
10.6.0 40,445 9/30/2021
10.5.1 2,259 9/22/2021
10.5.0 11,375 9/9/2021
10.4.1 662 9/3/2021
10.4.0 1,155 8/31/2021
10.3.0 54,827 7/7/2021
10.2.1 10,731 7/1/2021
10.2.0 13,069 6/15/2021
10.2.0-beta.2 411 5/5/2021
10.2.0-beta.1 208 4/12/2021
10.1.4 8,702 5/12/2021
10.1.3 8,555 4/29/2021
10.1.2 12,959 3/19/2021
10.1.1 9,489 2/25/2021
10.1.0 5,414 2/9/2021
10.0.1 1,914 2/2/2021
10.0.0-beta.6 289 1/26/2021
10.0.0-beta.5 476 1/19/2021
10.0.0-beta.3 1,003 12/10/2020
10.0.0-beta.2 1,267 11/4/2020
10.0.0-beta.1 578 10/16/2020
10.0.0-alpha.43 207 10/9/2020
10.0.0-alpha.34 328 10/4/2020
5.1.3 3,034 2/10/2021
5.1.2 45,506 10/20/2020
5.1.1 17,451 10/2/2020
5.1.0 3,046 9/30/2020
5.0.1 8,737 9/9/2020
4.3.0 161,816 2/5/2020
4.2.0 49,706 10/8/2019
4.1.0 50,612 8/6/2019
4.0.1 13,664 6/27/2019
4.0.0 4,271 6/14/2019
3.4.0 85,004 1/9/2019
3.3.0 20,714 11/8/2018
3.2.1 30,323 9/27/2018
3.2.0 10,107 9/4/2018
3.1.0 25,990 7/4/2018
3.0.0 102,658 4/16/2018
2.2.0 10,561 3/22/2018
2.1.0 48,054 11/13/2017
2.0.0 16,305 10/17/2017
2.0.0-rc1 1,048 10/3/2017
1.6.0 32,521 8/15/2017
1.5.0 15,960 6/20/2017
1.4.0 13,190 5/19/2017
1.3.0 2,222 5/16/2017
1.2.1 6,375 5/1/2017
1.2.0 4,397 4/4/2017
1.1.1 5,444 3/15/2017
1.1.0 2,227 3/3/2017
1.0.4 3,558 2/21/2017
1.0.3 15,575 2/14/2017
0.82.1 17,154 1/27/2017
0.82.0 1,720 1/23/2017
0.81.0 3,876 12/15/2016
0.80.0 7,610 10/27/2016
0.78.1 19,324 9/15/2016
0.78.0 1,504 9/11/2016
0.77.2 4,173 8/11/2016
0.77.1 1,722 7/28/2016
0.76.1 4,795 6/15/2016
0.76.0 1,420 6/9/2016
0.75.0 1,555 6/3/2016
0.74.1 3,848 5/10/2016

## 10.7.1 (2021-11-19)

### Fixed
* A sync user's Realm was not deleted when the user was removed if the Realm path was too long such that it triggered the fallback hashed name (this is OS dependant but is 300 characters on linux). (Core upgrade)
* Don't keep trying to refresh the access token if the client's clock is more than 30 minutes ahead. (Core upgrade)
* Don't sleep the sync thread artificially if an auth request fails. This could be observed as a UI hang on applications when sync tries to connect after being offline for more than 30 minutes. (Core upgrade)

### Compatibility
* Realm Studio: 11.0.0 or later.

### Internal
* Using Core 11.6.1.