PPWCode.Vernacular.NHibernate.II 4.3.0

.NET Standard 2.0 .NET Framework 4.8
Install-Package PPWCode.Vernacular.NHibernate.II -Version 4.3.0
dotnet add package PPWCode.Vernacular.NHibernate.II --version 4.3.0
<PackageReference Include="PPWCode.Vernacular.NHibernate.II" Version="4.3.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add PPWCode.Vernacular.NHibernate.II --version 4.3.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: PPWCode.Vernacular.NHibernate.II, 4.3.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install PPWCode.Vernacular.NHibernate.II as a Cake Addin
#addin nuget:?package=PPWCode.Vernacular.NHibernate.II&version=4.3.0

// Install PPWCode.Vernacular.NHibernate.II as a Cake Tool
#tool nuget:?package=PPWCode.Vernacular.NHibernate.II&version=4.3.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

The PPWCode Vernacular NHibernate library version II.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (5)

Showing the top 5 NuGet packages that depend on PPWCode.Vernacular.NHibernate.II:

Package Downloads
PPWCode.Vernacular.NHibernate.II.CastleWindsor

The PPWCode Vernacular NHibernate Castle Windsor library version II.

PPWCode.Vernacular.NHibernate.II.SqlServer

The PPWCode Vernacular NHibernate SQLServer library version II.

PPWCode.Vernacular.NHibernate.II.PostgreSQL

The PPWCode Vernacular NHibernate PostgreSQL library version II.

PPWCode.Vernacular.NHibernate.II.Firebird

The PPWCode Vernacular NHibernate Firebird library version II.

PPWCode.Util.Validation.II.NHibernate

The PPWCode Util Validation library version II

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
4.3.0 1,075 11/19/2021
4.2.0 854 2/4/2021
4.1.0 1,152 11/18/2020
4.0.0 1,146 4/24/2020
3.0.1 1,204 8/6/2019
2.0.4 4,651 1/21/2019
2.0.3 1,297 1/10/2019
2.0.2 12,143 12/20/2018
2.0.1 1,455 10/11/2018
2.0.0 1,342 10/2/2018
1.0.1 1,261 9/23/2018
1.0.0 7,541 9/19/2018

1.0.0 Initial release
1.0.1 Improve ordering of mapped types by pre-ordering them (workaround for a bug in nHibernate v5.1.3 and below)
2.0.0 Improvements
     - auxiliary database objects support multiple dialects (SQL Server, PostgreSQL, FireBird)
     - Hibernate HiLo generator follows settings in model mapper
2.0.1 Bugfix
     - AddSubResolverConditionally checked for CollectionResolver instead of the generic type
2.0.2 - Upgrade packages to latest version
     -   nHibernate (5.2.1) / nHibernate.Profiler (5.0.5031) / Remotion Linq (2.2.0)
         Firebird (6.4.0), PostgreSQL (4.0.4) and SqlServer ADO.Net drivers (4.6.0)
         Moq (4.10.1) and NUnit (3.11.0)
         Stylecop (1.1.1-beta.61)
     - Introduce support for caching (entities and associations) in SimpleModelMapper
2.0.3 - Upgrade packages to latest version
     -   nHibernate (5.2.2)
     -   Microsoft.SourceLink.GitHub (1.0.0-beta2-18618-05)
3.0.1 - Upgrade packages to latest version
     -   nHibernate (5.2.5) / NHibernateProfiler.Appender (5.0.5036)
         Firebird (6.6.0), PostgreSQL (4.0.8) and SqlServer ADO.Net drivers (4.6.1)
         Moq (4.12.0) and NUnit (3.13.0)
         Stylecop (1.1.118)
         Castle.Windsor (5.0.0)
     - Add object context to AuditLogEventListener
     - Support in repositories (LinqRepository, QueryOverRepository) for EmptyResultException
4.0.0 - Rework of IRepository / Repository / LinqRepository
       * Remove ILinqRepository interface, prevent leakage of queries outside our repository
       * improve documentation
       * add LoadById member to IRepository
       * Add support for Counting records
       * Add Async support for LinqRepository
       * Projecting an Entity to a Dto directly
     - HbmMapping / Auxillary
       * Including support for indices: covering / filtering for SQLServer / PostGre
       * Better support for many-to-many default mapping
     - Add a TContext type to the AuditLogEventListener
     - Upgrade packages to latest version
       * nHibernate (5.2.7)
       * NHibernateProfiler.Appender (5.0.5043)
       * Firebird (7.1.1)
       * PostgreSQL (4.1.2)
       * SqlServer ADO.Net drivers (4.8.0)
       * Moq (4.13.1)
       * NUnit (3.12.0)
       * Castle.Windsor (5.0.1)
     - re-arrange tests (namespaces, ..)
4.1.0 - Upgrade packages to latest version
       * nHibernate (5.3.5)
         ** IsActive on ITransaction should be replaced by GetCurrentTransaction()?.IsActive
       * NHibernateProfiler.Appender (5.0.5051)
       * PostgreSQL (4.1.4)
       * Moq (4.15.1)
       * System.Runtime.CompilerServices.Unsafe (4.5.4)
       * System.Diagnostics.DiagnosticSource (4.7.1)
       * System.Threading.Tasks.Extensions (4.5.4)
       * System.Data.SqlClient (4.8.2)
       * log4net (2.0.12)
       * Common Logging (3.4.1)
       * use Common.Logging.Log4Net.Universal (1.0.0) package for bridge between Common.Logging an log4net
       * Castle.Windsor (5.1.0)
4.2.0 - Upgrade packages to latest version
       * Castle.Windsor 5.1.0 -> 5.1.1
       * FirebirdSql.Data.FirebirdClient 7.5.0 -> 7.10.1
       * Npgsql 4.1.4 -> 5.0.3
       * NUnit 3.12.0 -> 3.13.1
       * Moq 4.15.1 -> 4.16.0
       * NHibernateProfiler.Appender 5.0.5051 -> 6.0.6019
       * System.Diagnostics.DiagnosticSource 4.7.1 -> 5.0.1
     - Introduce GetNextHi() in class HighLowPerTableAuxiliaryDatabaseObject
4.3.0 - Upgrade packages to latest version
       * nHibernate 5.3.5 -> 5.3.10
       * FirebirdSql.Data.FirebirdClient 7.10.1 -> 8.5.4
       * Npgsql 5.0.3 -> 6.0.0
       * System.Runtime.CompilerServices.Unsafe 5.0.0 -> 6.0.0
       * System.Data.SqlClient 4.8.2 -> 4.8.3 (netstandard20)
       * NUnit 3.13.1 -> 3.13.2
       * Moq 4.16.0 -> 4.16.1
       * NHibernateProfiler.Appender 6.0.6019 -> 6.0.6029
       * System.Diagnostics.DiagnosticSource 5.0.1 -> 6.0.0
     - Enhance Count, you can now use the Count functionality on a projection of TRoot