GiphyDotNet 2.0.0

.NET Standard 2.0
There is a newer version of this package available.
See the version list below for details.
dotnet add package GiphyDotNet --version 2.0.0
NuGet\Install-Package GiphyDotNet -Version 2.0.0
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="GiphyDotNet" Version="2.0.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add GiphyDotNet --version 2.0.0
#r "nuget: GiphyDotNet, 2.0.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install GiphyDotNet as a Cake Addin
#addin nuget:?package=GiphyDotNet&version=2.0.0

// Install GiphyDotNet as a Cake Tool
#tool nuget:?package=GiphyDotNet&version=2.0.0

GiphyDotNet

GiphyDotNet is a simple .NET wrapper library for the Giphy API. Giphy is a search engine for gifs, enabling developers to find new and interesting ways to intergrate gifs from the Internet into their applications (and ways for people in Marketing to annoy people like me with endless amounts of Cat gifs in Slack). GiphyDotNet is a way to consume to Giphy API without having to handle the requests yourself.

Getting Started

Simply go to Nuget and download the library. You can also get it directly from the package manager.

var giphy = new Giphy("apikey");
var searchParameter = new SearchParameter()
            {
                Query = "awesome"
            };
// Returns gif results
var gifResult = await giphy.GifSearch(searchParameter);

var stickerResult = await giphy.StickerSearch(searchParameter);

Gif By ID/IDs

var giphy = new Giphy("apikey");
var gifResult = await giphy.GetGifById("feqkVgjJpYtjy");
var gifsResult = await giphy.GetGifsByIds(new string[] { "feqkVgjJpYtjy", "7rzbxdu0ZEXLy" });

Random Gif/Sticker

var giphy = new Giphy("apikey");
var gifresult = await giphy.RandomGif(new RandomParameter()
{
   Tag = "american psycho"
});
var stickerresult = await giphy.RandomSticker(new RandomParameter()
{
   Tag = "american psycho"
});

Translate Into Gif/Sticker

var giphy = new Giphy("apikey");
var gifresult = await giphy.TranslateIntoGif(new RandomParameter()
{
   Tag = "american psycho"
});
var stickerresult = await giphy.TranslateIntoSticker(new RandomParameter()
{
   Tag = "american psycho"
});
var giphy = new Giphy("apikey");
var gifResult = await giphy.TrendingGifs(new TrendingParameter());
var stickerresult = await giphy.TrendingStickers(new TrendingParameter());

License

This library is licensed under the MIT License.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows net7.0 net7.0-android net7.0-ios net7.0-maccatalyst net7.0-macos net7.0-tvos net7.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on GiphyDotNet:

Package Downloads
Nami

Package Description

GitHub repositories (1)

Showing the top 1 popular GitHub repositories that depend on GiphyDotNet:

Repository Stars
Macro-Deck-org/Macro-Deck
Macro Deck converts your phone, tablet or any other device with an up-to-date internet browser into an powerful remote macro pad to perform single actions or even multiple actions with just one tap.
Version Downloads Last updated
2.4.0 905 6/24/2022
2.3.0 244 6/24/2022
2.2.0 259 6/22/2022
2.1.0 246 6/22/2022
2.0.0 7,035 11/19/2019
1.0.0 3,319 2/18/2016

- Now .NET Standard 2.0 compatible!