Fireblocks.Api 1.0.612

dotnet add package Fireblocks.Api --version 1.0.612
NuGet\Install-Package Fireblocks.Api -Version 1.0.612
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="Fireblocks.Api" Version="1.0.612" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Fireblocks.Api --version 1.0.612
#r "nuget: Fireblocks.Api, 1.0.612"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install Fireblocks.Api as a Cake Addin
#addin nuget:?package=Fireblocks.Api&version=1.0.612

// Install Fireblocks.Api as a Cake Tool
#tool nuget:?package=Fireblocks.Api&version=1.0.612

Fireblocks.Api

GitHub Build Status Nuget

Coverage Quality Gate Status Reliability Rating Security Rating Vulnerabilities

Description

This is a .NET6 library for interacting with the Fireblocks API.

Quick start

Installation

dotnet add package Fireblocks.Api

Appsettings.json

{
	"Fireblocks": {
		"ApiConfig": {
			"BaseUrl": "https://api.fireblocks.io",
			"Version": "v1",
			"ApiKey": "YOUR_API_KEY",
			"ApiSecret": "YOUR_API_SECRET"
		},
		"JwtConfig": {
			"ExpiredInSeconds": 25
		}
	}
}

Add configs & services

using Fireblocks.Api.Extensions;

ConfigureServices(IServiceCollection services, IConfiguration configuration)
{
	services
		.AddFireblocksApiConfigs(configuration);
		.AddFireblocksApiServices(configuration);
}

Using services

using Fireblocks.Api.Interfaces;
using Fireblocks.Api.Models.Responses;
using Fireblocks.Api.Services;

public class MyProcess
{
	private readonly IVaultService _vaultService;

	public MyProcess(IVaultService vaultService) =>
		_vaultService = vaultService;

	public async Task GetVaultAccountAsync()
	{
		var myVaultAccount = await _vaultService.GetVaultAccountAsync("YOUR_VAULT_ACCOUNT_ID");
	}
}

Reference

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
1.0.612 973 11/8/2022