FakeXrmEasy.Plugins.v9 3.4.1

The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org. Prefix Reserved
dotnet add package FakeXrmEasy.Plugins.v9 --version 3.4.1
NuGet\Install-Package FakeXrmEasy.Plugins.v9 -Version 3.4.1
This command is intended to be used within the Package Manager Console in Visual Studio, as it uses the NuGet module's version of Install-Package.
<PackageReference Include="FakeXrmEasy.Plugins.v9" Version="3.4.1" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add FakeXrmEasy.Plugins.v9 --version 3.4.1
#r "nuget: FakeXrmEasy.Plugins.v9, 3.4.1"
#r directive can be used in F# Interactive and Polyglot Notebooks. Copy this into the interactive tool or source code of the script to reference the package.
// Install FakeXrmEasy.Plugins.v9 as a Cake Addin
#addin nuget:?package=FakeXrmEasy.Plugins.v9&version=3.4.1

// Install FakeXrmEasy.Plugins.v9 as a Cake Tool
#tool nuget:?package=FakeXrmEasy.Plugins.v9&version=3.4.1

This package contains helpers to aid in developing and testing of plugins as well as pipeline simulation features.

Product Compatible and additional computed target framework versions.
.NET net6.0 is compatible.  net6.0-android was computed.  net6.0-ios was computed.  net6.0-maccatalyst was computed.  net6.0-macos was computed.  net6.0-tvos was computed.  net6.0-windows was computed.  net7.0 was computed.  net7.0-android was computed.  net7.0-ios was computed.  net7.0-maccatalyst was computed.  net7.0-macos was computed.  net7.0-tvos was computed.  net7.0-windows was computed.  net8.0 was computed.  net8.0-android was computed.  net8.0-browser was computed.  net8.0-ios was computed.  net8.0-maccatalyst was computed.  net8.0-macos was computed.  net8.0-tvos was computed.  net8.0-windows was computed. 
Compatible target framework(s)
Included target framework(s) (in package)
Learn more about Target Frameworks and .NET Standard.

NuGet packages (1)

Showing the top 1 NuGet packages that depend on FakeXrmEasy.Plugins.v9:

Package Downloads
FakeXrmEasy.v9 The ID prefix of this package has been reserved for one of the owners of this package by NuGet.org.

FakeXrmEasy is the open source test automation framework for .net core and the Power Platform / Dataverse. This is an include package.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.4.1 6,705 2/14/2024
3.3.3 10,446 10/22/2023
3.3.1 39,828 3/21/2023
3.3.0 23,378 12/27/2022
3.2.0 4,342 9/7/2022
3.1.2 3,195 6/14/2022
3.1.1 1,223 5/30/2022
3.1.0 952 5/20/2022
3.0.2 2,291 3/15/2022
3.0.1-rc1.3 249 12/6/2021
2.4.1 6,329 2/7/2024
2.4.0 404 2/6/2024
2.3.3 10,866 10/15/2023
2.3.2 9,825 5/17/2023
2.3.0 46,628 12/27/2022
2.2.0 12,145 9/7/2022
2.1.1 13,890 5/29/2022
2.1.0 4,543 4/10/2022
2.0.1-rc1.2 4,505 12/6/2021
2.0.1-rc1.1 174 11/23/2021

## [3.4.1]
### Changed
- Fix for GetServiceProvider should return null for unsupported types - https://github.com/DynamicsValue/fake-xrm-easy/issues/127
## [3.4.0]
### Added
- **Alpha**: Introduced subscription usage monitoring based on customer feedback
### Changed
- Set default build configuration in solution file to FAKE_XRM_EASY_9
- build.ps1 improvements: do not build project twice (added --no-build) when running dotnet test, do not build again either when packing assemblies either: https://github.com/DynamicsValue/fake-xrm-easy/issues/119
- Remove release notes from package description: https://github.com/DynamicsValue/fake-xrm-easy/issues/115
- Update build scripts to use 'all' target frameworks by default - https://github.com/DynamicsValue/fake-xrm-easy/issues/126
- Update github actions to use new Sonar environment variables - https://github.com/DynamicsValue/fake-xrm-easy/issues/120
## [3.3.3]
### Added
- Added [ExcludeFromCodeCoverage] to included generated PipelineType entities in src as it messes up code coverage metrics
- **[Possibly breaking change]** : Exception raised if both EntityTypeCode and EntityLogicalName are set when registering a plugin step. EntityTypeCode is deprecated, please move all plugin registrations to use EntityLogicalName instead.
- Introduced new user-defined exceptions to verify plugin step registrations when EntityTypeCode is used
- Adding support for secure and unsecure configurations in pipeline simulation - https://github.com/DynamicsValue/fake-xrm-easy/issues/103
### Changed
- Resolves an issue when using early bound types without pipeline types being generated caused plugin step registration to fail - https://github.com/DynamicsValue/fake-xrm-easy/issues/85
- Resolves an issue where the exception raised by a plugin was hidden because of reflection.
- Resolves an issue with PostImages: where attributes defined in a PluginStepDefintion of a PostImage event where not returned  - https://github.com/DynamicsValue/fake-xrm-easy/issues/102
- Update legacy CRM SDK 2011 dependency to use official MS package - https://github.com/DynamicsValue/fake-xrm-easy/issues/105
## [3.3.1]
### Changed
- Bump DataverseClient dependency to target net6 - https://github.com/DynamicsValue/fake-xrm-easy/issues/90
## [3.3.0]
### Changed
- Implement execution of custom apis, as well as registration of extra plugin steps against these apis - https://github.com/DynamicsValue/fake-xrm-easy/issues/50
- Allow execution of PreImages in prevalidation : https://github.com/DynamicsValue/fake-xrm-easy/issues/71
### Added
- Added execution of fake custom api's
- Added validation of preimages and postimages during plugin step registration - https://github.com/DynamicsValue/fake-xrm-easy/issues/33
- Added custom function to support registration of plugin steps via a custom reflection function (CustomPluginStepDiscoveryFunction) - https://github.com/DynamicsValue/fake-xrm-easy/issues/11
- First implementation (preview) of automatic registration of plugin steps via reflection - https://github.com/DynamicsValue/fake-xrm-easy/issues/11
### Changed
- IXrmFakedContextPluginExtensions is now IXrmBaseContextPluginExtensions. All extensions methods were changed to use the IXrmBaseContext interface as opposed to the IXrmFakedContext interface only so they could be used by both XrmFakedContext and XrmRealContext classes. - https://github.com/DynamicsValue/fake-xrm-easy/issues/35
## [3.2.0]
### Added
- OutputParameters is now populated in PipelineSimulation: DynamicsValue/fake-xrm-easy#39
- Plugin Step registration improvements: new general purpose method to register plugin steps: DynamicsValue/fake-xrm-easy#53
- Added possibility to register plugin steps with logical name, and therefore support for late bound registration DynamicsValue/fake-xrm-easy#38
### Changed
- Fix Sonar Quality Gate settings: DynamicsValue/fake-xrm-easy#28
## [3.1.2]
### Changed
- Bump dataverse dependency to 1.0.1
## [3.1.1]
### Changed
- Limit FakeItEasy package dependency to v6.x versions - DynamicsValue/fake-xrm-easy#37
- Updated build script to also include the major version in the Title property of the generated .nuspec file - DynamicsValue/fake-xrm-easy#41
## [3.1.0]
### Added
- New UsePluginStepRegistrationValidation that can be used to validate if a plugin step registration is valid - DynamicsValue/fake-xrm-easy#19 and DynamicsValue/fake-xrm-easy#33
- Improved performance of retrieval of Plugin steps, added benchmark tests DynamicsValue/fake-xrm-easy#14
- PluginStepAudit and new UsePluginStepAudit in PipelineOptions - DynamicsValue/fake-xrm-easy#19
- PreValidation execution in Pipeline Simulation - DynamicsValue/fake-xrm-easy#19
- PreImages and Postimages execution in Pipeline Simulation - DynamicsValue/fake-xrm-easy#19
- Triggering plugins in PipelineSimulation based on filtering attributes - DynamicsValue/fake-xrm-easy#19
- Support for ILogger and PluginTelemetry - DynamicsValue/fake-xrm-easy#24
### Changed
- Marked several execute plugin methods as obsolete
- Populate OwningExtension in plugin execution context from default fake plugin context DynamicsValue/fake-xrm-easy#17
- Populate PrimaryEntityId in plugin execution context from default fake plugin context DynamicsValue/fake-xrm-easy#8
- Fixed issue in push.ps1 script where it was just pushing the first package, using now a glob pattern
## [3.0.2]
### Changed
- Bump Dataverse dependency to 0.6.1 from 0.5.10 to solve DynamicsValue/fake-xrm-easy#20
- Also replaced Microsoft.Dynamics.Sdk.Messages dependency, as it has also been deprecated by MSFT, to Microsoft.PowerPlatform.Dataverse.Client.Dynamics 0.6.1 DynamicsValue/fake-xrm-easy#20
## [3.0.1-rc1] - Initial release