Evolve 2.1.0

There is a newer version of this package available.
See the version list below for details.
Install-Package Evolve -Version 2.1.0
dotnet add package Evolve --version 2.1.0
<PackageReference Include="Evolve" Version="2.1.0" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Evolve --version 2.1.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Evolve, 2.1.0"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Evolve as a Cake Addin
#addin nuget:?package=Evolve&version=2.1.0

// Install Evolve as a Cake Tool
#tool nuget:?package=Evolve&version=2.1.0
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Evolve is an easy migration tool that uses plain old sql scripts. Its purpose is to automate your database changes, and help keep those changes synchronized through all your environments and developpement teams.
Every time you build your project, it will automatically ensure that your database is up-to-date, without having to do anything other than build. Install it and forget it !

  • .NETFramework 3.5

    • No dependencies.
  • .NETFramework 4.6.1

    • No dependencies.
  • .NETStandard 2.0

    • No dependencies.

NuGet packages (2)

Showing the top 2 NuGet packages that depend on Evolve:

Package Downloads
GR.CommonsLib.DATA

.Net Commons project for Local Database Sqlite.

MicroTechFW.Data.Migrations.Evolve

Package Description

GitHub repositories (1)

Showing the top 1 popular GitHub repositories that depend on Evolve:

Repository Stars
lecaillon/Evolve
Database migration tool for .NET and .NET Core projects. Inspired by Flyway.
Version Downloads Last updated
3.1.0-alpha2 118 9/27/2021
3.1.0-alpha1 576 4/5/2021
3.0.0 122,454 3/21/2021
3.0.0-alpha6 117 3/14/2021
3.0.0-alpha5 149 3/7/2021
3.0.0-alpha4 119 2/19/2021
3.0.0-alpha3 95 2/17/2021
3.0.0-alpha2 219 2/16/2021
3.0.0-alpha1 86 2/15/2021
2.4.0 330,520 2/16/2020
2.3.0 87,988 10/14/2019
2.2.0 115,635 3/23/2019
2.1.0 34,958 2/23/2019
2.0.0 1,618 2/17/2019
1.9.0 28,020 10/10/2018
1.8.0 59,317 2/23/2018
1.7.0 6,335 11/8/2017
1.6.0 1,317 10/17/2017
1.5.1 2,371 9/14/2017
1.4.0 925 8/22/2017
1.3.2 1,260 7/11/2017
1.3.1 1,435 7/3/2017
1.3.0 904 6/28/2017
1.2.0 973 5/21/2017
1.1.0 836 4/28/2017
1.0.0 879 3/30/2017

- #30 Add support for loading scripts from embedded resources.
- #100 Fix: failed to parse PostgreSQL version in Debian based PostgreSQL containers.