Diassoft.DataAccess 3.0.3

.NET Core 2.0 .NET Standard 2.0 .NET Framework 4.5
There is a newer version of this package available.
See the version list below for details.
Install-Package Diassoft.DataAccess -Version 3.0.3
dotnet add package Diassoft.DataAccess --version 3.0.3
<PackageReference Include="Diassoft.DataAccess" Version="3.0.3" />
For projects that support PackageReference, copy this XML node into the project file to reference the package.
paket add Diassoft.DataAccess --version 3.0.3
The NuGet Team does not provide support for this client. Please contact its maintainers for support.
#r "nuget: Diassoft.DataAccess, 3.0.3"
#r directive can be used in F# Interactive, C# scripting and .NET Interactive. Copy this into the interactive tool or source code of the script to reference the package.
// Install Diassoft.DataAccess as a Cake Addin
#addin nuget:?package=Diassoft.DataAccess&version=3.0.3

// Install Diassoft.DataAccess as a Cake Tool
#tool nuget:?package=Diassoft.DataAccess&version=3.0.3
The NuGet Team does not provide support for this client. Please contact its maintainers for support.

Provides a set of classes to provide database access without using ORM. Ideal for the scenarios where you do not have a way to relate the database tables to objects.
Accepts Dialects to parse the sql statements accordingly to the database in use. Custom Dialects can be created.

Product Versions
.NET net5.0 net5.0-windows net6.0 net6.0-android net6.0-ios net6.0-maccatalyst net6.0-macos net6.0-tvos net6.0-windows
.NET Core netcoreapp2.0 netcoreapp2.1 netcoreapp2.2 netcoreapp3.0 netcoreapp3.1
.NET Standard netstandard2.0 netstandard2.1
.NET Framework net45 net451 net452 net46 net461 net462 net463 net47 net471 net472 net48
MonoAndroid monoandroid
MonoMac monomac
MonoTouch monotouch
Tizen tizen40 tizen60
Xamarin.iOS xamarinios
Xamarin.Mac xamarinmac
Xamarin.TVOS xamarintvos
Xamarin.WatchOS xamarinwatchos
Compatible target framework(s)
Additional computed target framework(s)
Learn more about Target Frameworks and .NET Standard.
  • .NETCoreApp 2.0

  • .NETFramework 4.5

    • No dependencies.
  • .NETFramework 4.5.1

    • No dependencies.
  • .NETFramework 4.5.2

    • No dependencies.
  • .NETFramework 4.6

    • No dependencies.
  • .NETFramework 4.6.1

    • No dependencies.
  • .NETStandard 2.0

NuGet packages

This package is not used by any NuGet packages.

GitHub repositories

This package is not used by any popular GitHub repositories.

Version Downloads Last updated
3.0.7 76 1/23/2022
3.0.4 371 1/1/2020
3.0.3 288 12/18/2019
3.0.2 289 12/17/2019
3.0.1 330 9/21/2019
3.0.0 290 9/3/2019
2.1.0 310 7/24/2019
2.0.0 342 3/18/2019
1.3.0 338 2/25/2019
1.2.0 364 2/25/2019
1.1.0 358 2/24/2019